大米CMS官网论坛,大米站长联盟,大米站长之家,大米开发者社区

 找回密码
 注册大米会员

QQ登录

只需一步,快速开始

查看: 1756|回复: 0

jquery版本冲突终极解决方法

[复制链接]

366

主题

625

帖子

5078

积分

超级版主

Rank: 8Rank: 8

积分
5078

授权用户

发表于 2015-11-2 15:38:07 | 显示全部楼层 |阅读模式
本帖最后由 追影 于 2015-12-16 11:30 编辑

  1. <!-- 引入1.6.4版的jq -->
  2. <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.6.4/jquery.js"></script>
  3. <script> var jq164 = jQuery.noConflict(true); </script>
  4. <!-- 引入1.4.2版的jq -->
  5. <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.js"></script>
  6. <script> var jq142 = jQuery.noConflict(true); </script>
  7. 插件类中:
  8. <script>
  9. (function($){
  10.     //此时的$是jQuery-1.6.4
  11.     $('#header');
  12. })(jq164);
  13. </script>

  14. <script>
  15. (function($){
  16.     //此时的$是jQuery-1.4.2
  17.     $('#footer');
  18. })(jq142);
  19. </script>
复制代码
  其他的只要将$符号变成对应的变量就可以了


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 注册大米会员

本版积分规则

QQ|小黑屋|大米CMS社区 ( 蜀ICP备11002200号-2广告联系:广告联系 

Powered by 大米CMS

© 2010-2020 大米CMS Inc.

快速回复 返回顶部 返回列表